RequirementsΒΆ

  • Arista EOS 4.12 or later
  • Arista eAPI enabled for at least one transport (see Official EOS Config Guide at arista.com for details)
  • Python 2.7 or 3.4+ (Python 3 support is work in progress)
  • Pyeapi requires the netaddr Python module

Note

netaddr gets installed automatically if you use pip to install pyeapi